Update Fortuna from 1.6 to 3.0


  • Member
    francescobrischetto
    May 4, 2021 at 1:28 pm #35479

    Hi,
    I’m trying to update fortuna theme for one customer in a local backup of the site.
    The site was running Fortuna 1.6 and Js_Composer 4.12.
    I’m getting errors when activating the composer plugin (while activating Fortuna 3.0 theme).
    Can you please help me?

    [04-May-2021 10:21:38 UTC] PHP Warning: The magic method Vc_Manager::__sleep() must have public visibility in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\js_composer.php on line 211
    [04-May-2021 10:21:38 UTC] PHP Warning: The magic method Vc_Manager::__wakeup() must have public visibility in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\js_composer.php on line 217
    [04-May-2021 10:21:38 UTC] PHP Deprecated: Required parameter $width follows optional parameter $attach_id in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\include\helpers\helpers.php on line 398
    [04-May-2021 10:21:38 UTC] PHP Deprecated: Required parameter $height follows optional parameter $attach_id in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\include\helpers\helpers.php on line 398
    [04-May-2021 10:21:38 UTC] PHP Fatal error: Unparenthesized a ? b : c ? d : e is not supported. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e) in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\include\classes\editors\class-vc-frontend-editor.php on line 648
    [04-May-2021 10:21:39 UTC] PHP Warning: The magic method Vc_Manager::__sleep() must have public visibility in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\js_composer.php on line 211
    [04-May-2021 10:21:39 UTC] PHP Warning: The magic method Vc_Manager::__wakeup() must have public visibility in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\js_composer.php on line 217
    [04-May-2021 10:21:39 UTC] PHP Deprecated: Required parameter $width follows optional parameter $attach_id in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\include\helpers\helpers.php on line 398
    [04-May-2021 10:21:39 UTC] PHP Deprecated: Required parameter $height follows optional parameter $attach_id in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\include\helpers\helpers.php on line 398
    [04-May-2021 10:21:39 UTC] PHP Fatal error: Unparenthesized a ? b : c ? d : e is not supported. Use either (a ? b : c) ? d : e or a ? b : (c ? d : e) in C:\xampp\htdocs\gestlabs-new\wp-content\plugins\js_composer\include\classes\editors\class-vc-frontend-editor.php on line 648

    Sorry, this forum is for verified users only. Please Login or Register to continue

Comments are closed.